Bug 60041 - Placeholder in Entry box is vertically aligned to bottom
Summary: Placeholder in Entry box is vertically aligned to bottom
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.4.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
: 60655 ()
Depends on:
Blocks:
 
Reported: 2017-10-08 13:15 UTC by Russell Corbin
Modified: 2018-05-11 00:54 UTC (History)
7 users (show)

Tags: placeholder, alignment, ac fr
Is this bug a regression?: Yes
Last known good build: 2.3.4.270

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Russell Corbin 2017-10-08 13:15:00 UTC
Latest Xamarin.Forms.Nuget package broken. Last known working version is 2.3.4.270.

Create blank app, add the following: 
<Entry Placeholder="Test text" HorizontalOptions="Center" VerticalOptions="Center" WidthRequest="200" HeightRequest="40" />

Placeholder text is vertically aligned to bottom whereas normal text is center aligned.
Setting vertical alignment through renderer does not work either.
Comment 1 Paul DiPietro [MSFT] 2017-10-09 19:31:15 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1190
Comment 2 Samantha Houts [MSFT] 2017-10-13 18:34:39 UTC
Should be fixed in 2.4.0 SR2. Thank you!
Comment 3 batmaci 2017-10-24 16:05:05 UTC
Is it included in 2.5 pre?
Comment 4 Paul DiPietro [MSFT] 2017-10-24 16:31:07 UTC
There was some accidental shuffling around of the broken code for some reason, so it will be in what I assume is the very next release. A PR is already up and it should be in soon.
Comment 5 Samantha Houts [MSFT] 2017-10-24 18:42:07 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1220
Comment 6 Samantha Houts [MSFT] 2017-10-27 17:42:03 UTC
Should be fixed in 2.4.0 SR3 and 2.5.0-pre3. Thanks!
Comment 7 Paul DiPietro [MSFT] 2017-11-13 21:58:06 UTC
*** Bug 60655 has been marked as a duplicate of this bug. ***
Comment 8 Joel 2017-11-14 20:36:45 UTC
This doesn't appear to be fixed in 2.4.0 SR3 (2.4.0.38779). I have a sample project using Xamarin.Forms 2.4.0.38779 here: https://drive.google.com/open?id=1LWNk5k-okMdzfp90ACgLy6ztypFuZyu-

I'm still seeing the same issue. Am I missing something?
Comment 9 Paul DiPietro [MSFT] 2017-11-17 16:57:54 UTC
*** Bug 60655 has been marked as a duplicate of this bug. ***
Comment 10 Samantha Houts [MSFT] 2017-11-20 20:44:42 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1286
Comment 11 Rui Marinho 2017-12-05 19:19:49 UTC
Should be fixed in 2.5.0-sr3
Comment 12 Valene 2018-05-11 00:54:44 UTC
Hi, this issue is not fixed.I am still seeing the same issue again.