Bug 5993 - Cannot install to device.
Summary: Cannot install to device.
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-07-05 16:39 UTC by Laszlo Peter
Modified: 2012-07-06 08:46 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Laszlo Peter 2012-07-05 16:39:04 UTC
I have trouble installing a sample app on my iPhone. No problems with simulator. Versions: Monotouch 5.2.12, xcode 4.3.3. MacOS 10.7.4, iOS on target 5.1.

Deploy output in MonoDevelop is:
/Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" -installdev "/Users/lpeter/Projects/EasyCalculator01/EasyCalculator01/bin/iPhone/Release/EasyCalculator01.app"
Please ensure your device is connected...
Connected to: xx
Initializing file service...
Uploading application
Finalizing file service...
Installing application
Installation failed: AMDeviceInstallApplication returned: 0xe8008018
The application was terminated by a signal: SIGHUP
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-07-06 05:04:19 UTC
What is printed to the device log (MonoDevelop's menu: View -> Pads -> iOS Device Log) when this happens?
Comment 2 Laszlo Peter 2012-07-06 08:01:54 UTC
This is the iOS Log on my iPhone:

Jul  6 13:53:24 IP lockdownd[26] <Error>: libMobileGestalt computeUniqueDeviceID: total time for bb to return imei: 0
Jul  6 13:53:24 IP lockdownd[26] <Error>: libMobileGestalt computeUniqueDeviceID: total time for bb to return imei: 0
Jul  6 13:53:24 IP lockdownd[26] <Error>: libMobileGestalt computeUniqueDeviceID: total time for bb to return imei: 0
Jul  6 13:53:24 IP lockdownd[26] <Error>: libMobileGestalt computeUniqueDeviceID: total time for bb to return imei: 0
Jul  6 13:53:24 IP lockdownd[26] <Error>: libMobileGestalt computeUniqueDeviceID: total time for bb to return imei: 0
Jul  6 13:53:26 IP installd[516] <Error>: libMobileGestalt computeUniqueDeviceID: total time for bb to return imei: 0
Jul  6 13:53:27 IP installd[516] <Error>: developer cert trust result = 5
Jul  6 13:53:27 IP installd[516] <Error>: 00381000 verify_signer_identity: Could not copy validate signature: -402620392
Jul  6 13:53:27 IP installd[516] <Error>: 00381000 preflight_application_install: Could not verify executable at /var/tmp/install_staging.grjn59/EasyCalculator01.app
Jul  6 13:53:27 IP mobile_installation_proxy[515] <Error>: handle_install: Installation failed
Jul  6 13:53:27 IP installd[516] <Error>: 00381000 install_application: Could not preflight application install
Jul  6 13:53:27 IP installd[516] <Error>: 00381000 handle_install: API failed
Jul  6 13:53:27 IP installd[516] <Error>: 00381000 send_message: failed to send mach message of 71 bytes: 10000003
Jul  6 13:53:27 IP installd[516] <Error>: 00381000 send_error: Could not send error response to client
Jul  6 13:54:06 IP CommCenter[57] <Notice>: removing received message 2147483649
Jul  6 13:54:34 IP CommCenter[57] <Notice>: queuing sms message with id 1763
Jul  6 13:54:34 IP SpringBoard[52] <Error>: mms: queued messageId 1763
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-07-06 08:46:07 UTC
If you google for "Could not copy validate signature: -402620392" you'll see that it's most likely a problem with your provisioning profile(s).

I would first ensure that I can deploy apps successfully using Xcode, since Xcode in some cases does magic behind the scenes to make things work wrt provisioning profiles. Once Xcode works, then I'd try the MonoTouch project again (remember to do a clean & rebuild).

I'll close this bug report for now, please reopen if you still can't make it work after you've ensured that it works with Xcode.