Bug 5989 - Drag and drop duplicates controls instead of moving them on Windows MD
Summary: Drag and drop duplicates controls instead of moving them on Windows MD
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.2.x
Hardware: PC Windows
: Highest critical
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
: 5990 ()
Depends on:
Blocks:
 
Reported: 2012-07-05 12:17 UTC by PJ
Modified: 2013-05-08 11:14 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description PJ 2012-07-05 12:17:37 UTC
Steps to reproduce:

1) Open main.axml of new MFA app
2) Add a 2nd button
3) Drag the "Hello World, Click me!" button below the added button

Expected behavior:
Buttons should re-order

Actual behavior:
Button is duplicated in the new location.

I would love to screencast this issue, but for some reason drag and drop doesn't work at all with jing running. After releasing any control, it returns to its previous location without moving (or duplicating).

Environment:
Windows 7 / Windows 8
MD 3.0.3.3 RC3
MFA 4.2.4 RC2
Comment 1 PJ 2012-07-05 12:20:09 UTC
*** Bug 5990 has been marked as a duplicate of this bug. ***
Comment 2 PJ 2012-08-01 15:04:30 UTC
The team is still reporting this issue. Increasing the priority because this is essentially breaking the designer on Windows MD.
Comment 4 Lluis Sanchez 2013-03-11 08:44:15 UTC
The new gtk# for Windows doesn't seem to have this problem. Closing.
Comment 5 Nischal 2013-03-19 07:23:20 UTC
We have verified this issue with the latest version of GTK and the Latest builds:

GTK 2.12.20
XS 4.0.2.22
MFA 4.6.01072
Windows 7 and 8

And still the same issue exists, as the Drag and drop duplicates controls instead of moving them on Windows XS

Hence, reopening this issue.
Comment 6 Lluis Sanchez 2013-03-22 09:25:21 UTC
My bad, I was testing Visual Studio. 

This looks like a windows GTK bug. We start a drag allowing Copy and Move, and GTK is using Copy as default if no modifier key is pressed, while it uses Move as default in Mac and Linux.
Comment 7 Carlos Garnacho 2013-04-08 09:11:21 UTC
I've been investigating this bug for a while, although I've reached a point where I would need to check the MFA plugin code... As far as I could check, GTK+ does not specifically suggest a Copy operation (this can also be seen visually as there's no + symbol appearing on the Dn'D cursor icon). So AFAICT from my peeking at GTK+ behavior, the interpretation of the DnD operation as a Copy one seems to happen on the dest side
Comment 8 Lluis Sanchez 2013-04-10 13:21:14 UTC
There are some inconsistencies between Mac and Windows. On Windows, if no modifier key is pressed, GTK provides "Copy" as suggested action. In mac, it provides Copy | Move | Link. I added some workaround code that should fix our issue. I guess we can close for now.
Comment 9 narayanp 2013-04-15 07:33:32 UTC
We have check this issue with latest build:
X.S 4.0.3.13
MFA 4.7.04013

On VS 2010/12 when we try to drag the widgets, it works like 'Cut' and 'Paste'. 

However, on XS(Windows) when we try to drag the widgets, it works like 'Copy' and 'Paste'.

So the issue is still exist with XS on Windows.

As per our understanding this issue should be reopened.

PJ, Please look into it.
Comment 10 PJ 2013-04-22 12:40:29 UTC
You won't see this fix until the next 4.1.x Xamarin Studio, probably.
Comment 11 narayanp 2013-05-08 11:14:44 UTC
We have checke this issue with latest XS 4.0.5.4 build. Now this issue does not exist.

On XS(Windows) when we try to drag the widgets in designer page, it does not duplicates controls on Drag and drop, it works like 'Cut' and 'Paste', which is fine.

Build info:
GTK 2.12.21
XS 4.0.5.4
MFA 4.7.4-14

Hence, closing this issue.