Bug 59821 - INSTALL_FAILED_NO_MATCHING_ABIS should present a better error to the user
Summary: INSTALL_FAILED_NO_MATCHING_ABIS should present a better error to the user
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 7.4 (15.3)
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2017-09-28 14:56 UTC by Jon Dick
Modified: 2017-10-25 19:06 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59821 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Jon Dick 2017-09-28 14:56:09 UTC
If you try to run a build of an android app on a device which has an architecture not matching any of those in the build (For instance, if you build an app with only `armeabi-v7` and try deploy to an `x86_64` emulator), you get a cryptic error about unable to deploy to device.

If you try and install the .apk via adb `adb install com.some.app.apk` it returns an error code of:
INSTALL_FAILED_NO_MATCHING_ABIS

We should detect this and present a better error to the user with a suggestion to correct it.
Comment 1 Jon Douglas [MSFT] 2017-09-28 15:19:39 UTC
I have an existing comment on a bug that I've marked enhancement that might help with this effort:

https://bugzilla.xamarin.com/show_bug.cgi?id=58594#c3

This seems like a general enhancement compared to the specific situation in 58594 and thus I am CONFIRMING this behavior.
Comment 2 Greg Munn 2017-10-25 19:06:44 UTC
I initially moved this to VSMac because we addressed this specific issue, however, I think in general the install target should do this so that users using the cmdline or XVS can benefit from this as well.