Bug 59730 - Android Oreo style notifications give MissingMethodException in Preview Support Compat library
Summary: Android Oreo style notifications give MissingMethodException in Preview Suppo...
Status: RESOLVED ANSWERED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Staging (addons.xamstage.com)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jon Dick
URL:
Depends on:
Blocks:
 
Reported: 2017-09-25 20:29 UTC by Jason DeBoever
Modified: 2017-09-29 19:36 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
logcat of bug (16.13 KB, text/plain)
2017-09-25 20:29 UTC, Jason DeBoever
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Jason DeBoever 2017-09-25 20:29:27 UTC
Created attachment 24922 [details]
logcat of bug

Specifically the NotificationCompat.Builder constructor with the overload that accepts channel, as well as the SetChannel method throw MissingMethodException

Logcat attached.
Comment 1 Jon Dick 2017-09-26 18:54:01 UTC
Do you have a reproducible solution for this?  I can't seem to make it fail here.

One thing to try is deleting your bin/ and obj/ folders, and `adb uninstall com.your.package` from the device before rebuilding and trying again (especially if you just updated your nuget packages between debug builds).
Comment 2 Jon Dick 2017-09-29 19:36:34 UTC
Fixed :)