Bug 59644 - Trigger value does not work with {x:Null}
Summary: Trigger value does not work with {x:Null}
Status: RESOLVED DUPLICATE of bug 57863
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-21 13:01 UTC by Ruslan Zakharov
Modified: 2017-09-21 14:10 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 57863

Description Ruslan Zakharov 2017-09-21 13:01:01 UTC
# Steps to reproduce
1) Create code in XAML:
    <Image Source="{TemplateBinding Image}">
        <Image.Triggers>
            <DataTrigger TargetType="Image" Binding="{TemplateBinding Image}" Value="{x:Null}">
                <Setter Property="IsVisible" Value="False" />
            </DataTrigger>
        </Image.Triggers>
    </Image>

# Expected behavior
Image should be hidden.

# Actual behavior
Image is visible. Trigger does not working with {x:Null}.

# Supplemental info (logs, images, videos)
None

# Test environment (full version information)
IDE - Visual Studio 2017
Xamarin.Forms - 2.3.5.233
Comment 1 Paul DiPietro [MSFT] 2017-09-21 14:10:22 UTC

*** This bug has been marked as a duplicate of bug 57863 ***