Bug 59526 - Cannot Debug on Android 8.0 (API 26) Devices
Summary: Cannot Debug on Android 8.0 (API 26) Devices
Status: RESOLVED DUPLICATE of bug 56740
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 8.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-15 16:57 UTC by kyle.spearrin
Modified: 2017-09-15 17:03 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Basic blank android app used to test with (8.55 KB, application/x-zip-compressed)
2017-09-15 16:57 UTC, kyle.spearrin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56740

Description kyle.spearrin 2017-09-15 16:57:26 UTC
Created attachment 24781 [details]
Basic blank android app used to test with

I recently installed VS 15.4 preview 2 and installed Android 8.0 SDK/Tools.

I can create a brand new, blank Xamarin.Android app and can launch it to debug on an API 25 AVD device just fine, however, if I try the same app on an API 26 device (AVD or my Nexus 5X) the debugger does not work. The application builds and deploys to the device, but when the debugger tries to connect (status bar in VS turns from blue to orange) it immediately terminates the debugging session. All that I am left with in the Output Debug window is:

> Android application is debugging.
> Couldn't connect to logcat, GetProcessId returned: 0

On the device, I can see and launch my app from it (since it was deployed) and it works without issue.
Comment 1 kyle.spearrin 2017-09-15 16:59:14 UTC
VS Info
=====================

Microsoft Visual Studio Enterprise 2017 Preview (2)
Version 15.4.0 Preview 2.0
VisualStudio.15.Preview/15.4.0-pre.2.0+26906.1
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise

Visual Basic 2017   00369-60000-00001-AA734
Microsoft Visual Basic 2017

Visual C# 2017   00369-60000-00001-AA734
Microsoft Visual C# 2017

Visual F# 4.1   00369-60000-00001-AA734
Microsoft Visual F# 4.1

Application Insights Tools for Visual Studio Package   8.9.00809.2
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2017   15.0.30819.0
ASP.NET and Web Tools 2017

ASP.NET Core Razor Language Services   1.0
Provides languages services for ASP.NET Core Razor.

ASP.NET Web Frameworks and Tools 2017   5.2.50816.0
For additional information, visit https://www.asp.net/

Azure App Service Tools v3.0.0   15.0.30819.0
Azure App Service Tools v3.0.0

Common Azure Tools   1.10
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft Azure Tools   2.9
Microsoft Azure Tools for Microsoft Visual Studio 2017 - v2.9.50719.1

Microsoft Continuous Delivery Tools for Visual Studio   0.3
Simplifying the configuration of continuous build integration and continuous build delivery from within the Visual Studio IDE.

Microsoft JVM Debugger   1.0
Provides support for connecting the Visual Studio debugger to JDWP compatible Java Virtual Machines

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Mono Debugging for Visual Studio   4.7.4-pre (c2d89eb)
Support for debugging Mono processes with Visual Studio.

NuGet Package Manager   4.4.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

SQL Server Data Tools   15.1.61707.200
Microsoft SQL Server Data Tools

TypeScript   2.3.5.0
TypeScript tools for Visual Studio

Visual Studio Code Debug Adapter Host Package   1.0
Interop layer for hosting Visual Studio Code debug adapters in Visual Studio

VisualStudio.IoT   1.0
Package with IoT components for Visual Studio

VisualStudio.Mac   1.0
Mac Extension for Visual Studio

Xamarin   4.7.0.934 (d68a92f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.5.0.15 (HEAD/cf9532456)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.14.0.26 (416f778)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 2 Jon Douglas [MSFT] 2017-09-15 17:03:06 UTC
Please see our workaround until this ships in 15.4 Preview 3.

https://bugzilla.xamarin.com/show_bug.cgi?id=56740#c20

*** This bug has been marked as a duplicate of bug 56740 ***