Bug 59516 - Add fix from Bug 59015 - SIGABRT after executing async method
Summary: Add fix from Bug 59015 - SIGABRT after executing async method
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Linker ()
Version: 8.1 (15.5)
Hardware: PC Mac OS
: --- blocker
Target Milestone: 15.5
Assignee: Zoltan Varga
URL:
: 59744 ()
Depends on:
Blocks:
 
Reported: 2017-09-15 12:30 UTC by Radek Doulik
Modified: 2017-10-31 11:24 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Radek Doulik 2017-09-15 12:30:28 UTC
The bug was fixed in macios and looks like we will need this fix as well.
Comment 1 Radek Doulik 2017-09-19 13:59:08 UTC
Meanwhile I have created PR for the linker fix https://github.com/xamarin/xamarin-android/pull/875
Comment 2 Radek Doulik 2017-09-19 20:31:00 UTC
The PR made it to d15-5 branch.

The assert with linker disabled still remains, so reassigning to Zoltan.

I wasn't lucky when trying to attach gdb to the app on the emulator. Maybe it clashes with ?sdb? running at the same time? No idea.
Comment 3 Zoltan Varga 2017-09-19 20:35:16 UTC
This might be related to:

https://bugzilla.xamarin.com/show_bug.cgi?id=58728

I.e. instead of crashing, we hit this assert.
Comment 4 Marek Safar 2017-09-26 13:16:09 UTC
*** Bug 59744 has been marked as a duplicate of this bug. ***
Comment 5 Peter Collins 2017-10-11 19:29:35 UTC
This has been fixed in xamarin-android/d15-5/012c3112