Bug 59444 - Image not update in some cells/rows in ListView after vertical scrolling
Summary: Image not update in some cells/rows in ListView after vertical scrolling
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.4.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-13 10:36 UTC by Divakar
Modified: 2017-11-14 00:50 UTC (History)
6 users (show)

Tags: image, scroll, visibility, ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample which reproduce the reported issue "Image not update in some cells after vertical scrolling in ListView" (312.29 KB, application/x-zip-compressed)
2017-09-13 10:36 UTC, Divakar
Details
Screenshot which shows the actual issue "Image not update in some cells after vertical scrolling in ListView" (212.36 KB, image/png)
2017-09-13 10:37 UTC, Divakar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59444 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Divakar 2017-09-13 10:36:17 UTC
Created attachment 24715 [details]
Sample which reproduce the reported issue "Image not update in some cells after vertical scrolling in ListView"

Hi Team,

The image in some of the cells in ListView not updated after vertical scrolling(if you fling vertically fast). For example, if we load two images in each row of the ListView with the same image source and fling vertically fast, the reported issue will reproduce. The same case works fine if we load different image source for each image view loaded inside an each row of the ListView and also this case will work if we load only one image view inside an each row of the ListView.

We have attached the issue reproducible sample and issue screenshot in the attachments for your reference. Please note that we have reproduced this issue in Moto-e device(API level 19) with latest xamarin nuget package (2.3.4.270).

Regards,
Divakar.
Comment 1 Divakar 2017-09-13 10:37:54 UTC
Created attachment 24716 [details]
Screenshot which shows the actual issue "Image not update in some cells after vertical scrolling in ListView"
Comment 2 Paul DiPietro [MSFT] 2017-09-13 15:47:47 UTC
Updating to reflect 2.4.0 testing (against an API 23 emulator) where this issue occurs.