Bug 59384 - Cannot deploy an app with today's extension on my device
Summary: Cannot deploy an app with today's extension on my device
Status: RESOLVED DUPLICATE of bug 56748
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 10.99 (xcode9)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-11 12:23 UTC by Jonathan ANTOINE
Modified: 2017-09-11 13:21 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Visual Studio build logs (872.84 KB, text/plain)
2017-09-11 12:37 UTC, Jonathan ANTOINE
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56748

Description Jonathan ANTOINE 2017-09-11 12:23:31 UTC
Hello,

I build from Visual Studio 2015 (up to date) with the latests up-to-date xamarin plugins.

I have an iOs app deploying fine on my device.
I created a todays' extension and referenced it from my main project.

It deploys nicely on the simulator but when I try to deploy it on my device, I get this error :

	Tool exited with code: 1. Output: ditto: can't get real path for source '../../TVST.iOS.TodayExtension/bbab0075a4479dbc3ffaa583c620852f/bin/iPhone/Debug/device-builds/iphone8.1-10.3.3/TVST.iOS.TodayExtension.appex'	TVST.iOS.UI	C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets	1518	



I noticed that, on disk, there is no "/device-builds/iphone8.1-10.3.3" folder with files in it.

Thanks for your help.
Comment 1 Jonathan ANTOINE 2017-09-11 12:37:33 UTC
Created attachment 24678 [details]
Visual Studio build logs
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-09-11 12:42:31 UTC
IIRC this might be an issue we had if the "device specific build" option was not the same for both the extension and main project (which should be fixed in an upcoming release).

Can you check the project options of both the main and extension projects, and see if this is the case (and if so, change them to match; you can either disable or enable both, that's your choice).
Comment 3 Jonathan ANTOINE 2017-09-11 12:51:58 UTC
Thanks a lot Rolf, you saved my day !

(This was indeed the issue)
Comment 4 Rolf Bjarne Kvinge [MSFT] 2017-09-11 13:21:35 UTC
Great!

*** This bug has been marked as a duplicate of bug 56748 ***