Bug 59322 - error deploying iOS app on iOS 11
Summary: error deploying iOS app on iOS 11
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.99 (xcode9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Xcode9
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-08 09:33 UTC by Benjamin Müller
Modified: 2017-09-12 02:48 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
build log (201.16 KB, text/plain)
2017-09-08 09:33 UTC, Benjamin Müller
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Benjamin Müller 2017-09-08 09:33:37 UTC
Created attachment 24639 [details]
build log

Please Help.

We have built an app that can be deployed on ios 10 simulator and works and cannot be deployed on ios 11 simulator/device.

Attached the log.
Comment 1 Manuel de la Peña [MSFT] 2017-09-08 14:22:02 UTC
Hello, looking at the error:

   Process exited with code 1, command:
    /Applications/Xcode-beta.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang  -Wno-receiver-forward-class -gdwarf-2 -I/Library/Frameworks/Xamarin.iOS.framework/Versions/10.12.0.20/SDKs/MonoTouch.iphoneos.sdk/usr/include -isysroot /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.0.sdk -Qunused-arguments -miphoneos-version-min=8.0 -arch arm64 -c -o /Users/ibenm24/SecureSystemGuard/iOS/obj/iPhone/Debug/device-builds/iphone8.2-11.0/mtouch-cache/arm64/registrar.o -x objective-c++ -DDEBUG /Users/ibenm24/SecureSystemGuard/iOS/obj/iPhone/Debug/device-builds/iphone8.2-11.0/mtouch-cache/registrar.m
    In file included from /Users/ibenm24/SecureSystemGuard/iOS/obj/iPhone/Debug/device-builds/iphone8.2-11.0/mtouch-cache/registrar.m:3:
    /Users/ibenm24/SecureSystemGuard/iOS/obj/iPhone/Debug/device-builds/iphone8.2-11.0/mtouch-cache/registrar.h:14:9: fatal error: 'QuartzCore/CAEmitterBehavior.h' file not found
    #import <QuartzCore/CAEmitterBehavior.h>
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    1 error generated.
    
Looks like you need to update the Xcode setting in Visual Studio for Mac to point to an Xcode 9 version with the xcode9 branch Can you please try changes the setup and also provide the entire environment information?

Easiest way to get exact version information:
- On Visual Studio for Mac: "Visual Studio" menu, "About Visual Studio" item, "Show Details" button.
- On Visual Studio for Windows: "Help menu", "About Microsoft Visual Studio" item.
Then copy/paste the version information (you can use the "Copy Information" button).
Comment 2 Sebastien Pouliot 2017-09-12 02:48:10 UTC
As mentioned in comment #1 the error is a mismatch of Xamarin.iOS (stable) with a beta Xcode 9.

You need to install XI 10.99 preview if you want to use Xcode 9 (beta) and the new iOS 11 SDK (beta).