Bug 59227 - AutomationId's are not applied to ViewCell
Summary: AutomationId's are not applied to ViewCell
Status: NEEDINFO
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-05 12:03 UTC by Lewis Todd
Modified: 2017-09-08 08:15 UTC (History)
2 users (show)

Tags: automation, viewcell
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59227 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEEDINFO

Description Lewis Todd 2017-09-05 12:03:55 UTC
Automation Id's are not applied to Viewcells for android or iOS.
Comment 1 David Ortinau [MSFT] 2017-09-07 16:23:53 UTC
That's correct. What are you wanting to accomplish? Please elaborate on your use case.
Comment 2 Lewis Todd 2017-09-08 08:15:13 UTC
The scenario i'm looking at is testing a templated list view. I was trying to find cells of a particular type (via the automation id) and then verify data/actions on their content, ignoring other cells.

I can achieve this by applying the AutomationId to elements of the inner cell layout but it doesn't make sense that they are not applied when set via the base class property.