Bug 59195 - The operation CreateSession failed due to an internal error: Could not initialize class mono.android..D3DImageFactory
Summary: The operation CreateSession failed due to an internal error: Could not initia...
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 6.0.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2017-09-02 20:40 UTC by Minase
Modified: 2017-09-05 15:58 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Snapshot of the error (122.28 KB, image/png)
2017-09-02 20:40 UTC, Minase
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Minase 2017-09-02 20:40:46 UTC
Created attachment 24533 [details]
Snapshot of the error

HI.

I am new to android development using VS 2017 and xamarin.

the error happened when i clicked main.xml file :

The operation CreateSession failed due to an internal error: Could not initialize class mono.android..D3DImageFactory


java.lang.NoClassDefFoundError: Could not initialize class mono.android.D3DImageFactory
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:264)
	at mono.android.DesignerSession.initializePlatformSpecific(DesignerSession.java:86)
	at mono.android.DesignerSession.<init>(DesignerSession.java:75)
	at mono.android.Project.createSession(Project.java:382)
	at mono.android.Project.processMessage(Project.java:414)
	at mono.android.MessageListener.executeMessage(MessageListener.java:88)
	at mono.android.MessageListener$Runner.run(MessageListener.java:44)
	at java.lang.Thread.run(Thread.java:748)
Comment 1 Jon Douglas [MSFT] 2017-09-05 15:58:16 UTC
This issue stems from not using a JDK 1.8 that is x64. There is documentation on this item that you can find here:

https://developer.xamarin.com/releases/android/xamarin.android_7/xamarin.android_7.4/#System_Requirements

Please try to uninstall other JDK versions and install JDK 1.8 x64 from Oracle to see if this resolved the issue. If it does not, please reopen this bug.

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Thanks for the report!