Bug 59162 - Mono crash when using Forms previewer
Summary: Mono crash when using Forms previewer
Status: CONFIRMED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms Previewer ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-31 22:15 UTC by Bret Johnson [MSFT]
Modified: 2017-09-22 20:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Designer log (57.30 KB, text/plain)
2017-08-31 22:15 UTC, Bret Johnson [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59162 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description Bret Johnson [MSFT] 2017-08-31 22:15:59 UTC
Created attachment 24509 [details]
Designer log

Follow the same steps as https://bugzilla.xamarin.com/show_bug.cgi?id=59161:

Clone and build the Acquaint sample app: https://github.com/xamarinhq/app-acquaint

For the Debug build, changing the Linking from "Sdk Assemblies Only" to None. That's needed to work around another bug (https://bugzilla.xamarin.com/show_bug.cgi?id=59115)

Open the Previewer on the AcquaintanceEdtPage.xaml
Then open AcquaintanceDetailPage.xaml


In addition to the bug noted in 59161 (exception popup doesn't work), there's also a native crash here (snippet below, full log attached).

[2017-08-31 17:51:34.2] INFO: : =================================================================
[2017-08-31 17:51:34.2] INFO: : Got a SIGSEGV while executing native code. This usually indicates
[2017-08-31 17:51:34.2] INFO: : a fatal error in the mono runtime or one of the native libraries 
[2017-08-31 17:51:34.2] INFO: : used by your application.
[2017-08-31 17:51:34.2] INFO: : =================================================================

That's especially concerning as it can indicate a monodroid bug.
Comment 1 Alan McGovern 2017-08-31 22:23:34 UTC

*** This bug has been marked as a duplicate of bug 59161 ***
Comment 2 Alan McGovern 2017-08-31 22:23:42 UTC
This looks like a direct duplicate
Comment 3 Bret Johnson [MSFT] 2017-09-01 01:08:22 UTC
Reopening, as it feels like we'd want to track this separately.
This bug looks to be a MonoDroid or Xamarin.Android native crash, with fix needed there.

Bug 59161 is about our exception popup being flaky, with fix needed on the designer side.

It so happens that this same scenario can demonstrate both problems, but I'm pretty sure they are separate issues, and other scenarios would just show one problem or the other.