Bug 59142 - Designer does not sync 'Name' property correctly
Summary: Designer does not sync 'Name' property correctly
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Alexander Sorokin
URL:
Depends on:
Blocks:
 
Reported: 2017-08-31 11:11 UTC by Paul Sinnema
Modified: 2017-09-13 09:05 UTC (History)
7 users (show)

Tags: Akvelon
Is this bug a regression?: ---
Last known good build:


Attachments
Video showing the Name sync problem (watch the 'Name' property field. (403.77 KB, video/mp4)
2017-08-31 11:11 UTC, Paul Sinnema
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Sinnema 2017-08-31 11:11:23 UTC
Created attachment 24499 [details]
Video showing the Name sync problem (watch the 'Name' property field.

When I open a .xib for the first time the 'Name' property of a component in the designer is not shown although I know it's there.

Steps to reproduce:
- Create a new xib and add a UITableView to it.
- Give the UITableView a name in the 'Name' field of the properties.
- Close the .xib
- Open the .xib in 'Code view' and check whether the name is there and mapped correctly.
- Open the .xib in the Designer
- Click on the UITableView - no Name is displayed in the 'Name' field of the properties.
- Click outside the View
- Click on the UITableView - the Name is now displayed correctly

This behavior can be observed all through the Designer, not just this example.

Version info:

Microsoft Visual Studio Professional 2017 
Version 15.3.3
VisualStudio.15.Release/15.3.3+26730.12
Microsoft .NET Framework
Version 4.7.02046

Xamarin   4.6.0.299 (b63523e27)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.4.0.21 (2851083)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.12.0.20 (80b8487)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 1 Alan McGovern 2017-08-31 17:17:39 UTC
This looks like the value isn't set when the property panel initializes for the first time, but is set for subsequent attempts.