Bug 59102 - mono --version no longer shows git commit in Mono 5.2
Summary: mono --version no longer shows git commit in Mono 5.2
Status: CONFIRMED
Alias: None
Product: Installers
Classification: Mono
Component: Linux packages ()
Version: 5.2.0 (2017-04)
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Jo Shields
URL:
Depends on:
Blocks:
 
Reported: 2017-08-29 20:47 UTC by Alexander Köplinger [MSFT]
Modified: 2017-09-08 14:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59102 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Alexander Köplinger [MSFT] 2017-08-29 20:47:22 UTC
Compare:

> $ mono --version
>Mono JIT compiler version 5.0.0 (Stable 5.0.0.100/9667aa6 Thu May 11 14:31:42 UTC 2017)

vs.

> $ mono --version
> Mono JIT compiler version 5.2.0.215 (tarball Mon Aug 14 15:50:54 UTC 2017)
Comment 1 Alexander Köplinger [MSFT] 2017-09-08 14:50:48 UTC
@Jo it'd still be great to get this fixed in 15.4 / Mono 5.4 assuming it just requires changes to the Linux packaging.