Bug 59096 - Assertion at mini-trampolines.c
Summary: Assertion at mini-trampolines.c
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-29 15:34 UTC by Zadark
Modified: 2017-09-16 00:45 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Zadark 2017-08-29 15:34:17 UTC
Observed during #make install (Linux 32 bit OS)
Post commit d0e103fcb4ed3f0ba867052f9b5a4ac71faa0226

Console response including initial stacktrace 

make[6]: Leaving directory '/home/user1/opensimdev/mono-master/mcs/class/corlib'
make[6]: Entering directory '/home/user1/opensimdev/mono-master/mcs/class/Mono.Security'
make install-local
make[7]: Entering directory '/home/user1/opensimdev/mono-master/mcs/class/Mono.Security'
MONO_PATH="./../../class/lib/build:$MONO_PATH" /home/user1/opensimdev/mono-master/runtime/mono-wrapper  ./../../class/lib/build/gacutil.exe /i ./../../class/lib/net_4_x-linux/Mono.Security.dll /f  /root /home/user1/opensimdev/mono-master-bin-mcs/lib /package 4.5
* Assertion at mini-trampolines.c:831, condition `mono_thread_is_gc_unsafe_mode ()' not met

Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Mono.Tools.Driver.symlink (string,string) [0x0001e] in <a8aa6a2f4b9d428e873656d5c568d28b>:0
  at Mono.Tools.Driver.Install (bool,string,string,string,string,string,string) [0x003e4] in <a8aa6a2f4b9d428e873656d5c568d28b>:0
  at Mono.Tools.Driver.Main (string[]) [0x00394] in <a8aa6a2f4b9d428e873656d5c568d28b>:0
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) [0x0001e] in <a8aa6a2f4b9d428e873656d5c568d28b>:0
/proc/self/maps:
08048000-08474000 r-xp 00000000 fd:02 804844     /home/user1/opensimdev/mono-master/mono/mini/mono-sgen
Comment 1 Zoltan Varga 2017-08-30 10:07:07 UTC
How reproducible is this ?
Comment 2 Zadark 2017-08-30 13:49:46 UTC
The issue is only apparent during the install process, make builds works as expected.

Fails consistently each time we run #make install

Revert to ec9a95d and #make install works fine

Additional info: Fedora FC21 32 bit
The whole process runs in user space which has not changed since we began following mono trunk.

We have tried a fresh clone and empty install location.
Comment 3 Zadark 2017-09-04 12:37:45 UTC
The issue is no longer evident and #make install works as expected.

Update to the current trunk is the only change, the system environment is the same.

Resolved?
Comment 4 Zoltan Varga 2017-09-04 14:19:39 UTC
It could a random issue.