Bug 5906 - Custom UI objects not displaying in visual designer
Summary: Custom UI objects not displaying in visual designer
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer ()
Version: 3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2012-06-28 08:09 UTC by André Ingar Sørensen
Modified: 2017-07-07 16:12 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description André Ingar Sørensen 2012-06-28 08:09:10 UTC
I have several custom UI elements that I have to use for my project. Every one of them is showing as grey boxes in the visual designer. I expect the same functionality here as every other Android design tools, as long as they derive from a View it should be displayed.
Comment 1 rdhartz 2012-11-10 03:22:14 UTC
VS 2010 toolbox item is empty when i add axml item.
i try open vs project solution with monodevelop, toolbox item on monodevelop empty too.
how to fix this problem?
Comment 3 Jose Gallardo 2016-12-23 03:04:07 UTC
Updating Component for visibility from the right team.
Comment 4 Pierce Boggan [MSFT] 2017-07-07 16:12:09 UTC
Thanks so much for taking the time to submit this report! I can confirm I am no longer able to reproduce this issue using the latest Visual Studio 15.3 preview builds. Marking this report as RESOLVED.

Screencast:
https://www.screencast.com/t/zDLyfsEcc