Bug 59020 - The value displayed above a Slider on UWP does not move when the page is scrolled
Summary: The value displayed above a Slider on UWP does not move when the page is scro...
Status: RESOLVED UPSTREAM
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-24 16:48 UTC by John Hardman
Modified: 2017-08-24 19:23 UTC (History)
3 users (show)

Tags: UWP ScrollView Slider
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot showing problem (73.36 KB, image/png)
2017-08-24 16:48 UTC, John Hardman
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description John Hardman 2017-08-24 16:48:12 UTC
Created attachment 24404 [details]
Screenshot showing problem

On the attached screenshot, the "150" circled in red is the value relating to the Slider some way below (also circled in red). The tooltip/thumbnail used for the value is such a long way from the Slider as the page has been scrolled, resulting in the Slider moving, but the tooltip/thumbnail not moving. If a page containing a Slider is scrolled, the Slider's tooltip/thumbnail should either move with the Slider or it should disappear. Remaining where it is is a bug.

To reproduce, just include a Slider among the children of a ScrollView on a ContentPage. Use the arrow keys on the keyboard to change the Slider value. Use the mouse on the scrollbar of the ScrollView to scroll the page.
Comment 1 Paul DiPietro [MSFT] 2017-08-24 19:23:59 UTC
This issue appears to be part of the native UWP control and behavior, where placing a Slider into a ScrollViewer does the same thing. We've brought this to the UWP team's attention.