Bug 5900 - Installation fails
Summary: Installation fails
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-28 02:08 UTC by Mozzis
Modified: 2013-05-14 19:25 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Installation Log (11.48 KB, text/plain)
2012-06-28 02:08 UTC, Mozzis
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mozzis 2012-06-28 02:08:54 UTC
Created attachment 2126 [details]
Installation Log

Platform: Windows 7 Ultimate 64 bit

I downloaded MonoDevelop and installed it successfully. When I try to create a new Mono for Android project, I get a dialog telling me I need to install the Mono for Android SDK.

I go to Xamarin.com and download the sdk installer for Windows. I enable automatic troubleshooting info. The installer shows me the welcome dialog, then a dialog listing requirements (Android SDK and Mono for Android, Visual Studio and MonoDevelop.) At the bottom is a message "Component detection task interrupted by exception." The More link shows the exception type as System.AggregateException due to "failure to parse Android repository manifest." 

This happens repeatably.

The installation log is attached.
Comment 1 Peter Collins 2013-05-14 19:25:26 UTC
The universal installer we currently offer [0] should prevent this issue from occurring. Please reopen this bug if you encounter any related issues after running our universal installer. 

[0]: http://xamarin.com/download