Bug 59 - Monodevelop is very slow to load or exit
Summary: Monodevelop is very slow to load or exit
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.4.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-07-25 19:24 UTC by Ethan Nagel
Modified: 2013-09-12 17:08 UTC (History)
4 users (show)

Tags: monodevelop slow load exit
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Ethan Nagel 2011-07-25 19:24:45 UTC
Sometimes Monodevelop can take a very long time to load or exit.  When the slowdown happens, both the startup and exit are impacted.  In my current case the Monodevelop wil freeze with the beachball of death for over 50 seconds before showing the welcome screen. This is currently happening while I'm at a super slow Starbucks WIFI location.

Closing Monodevelop with a project open takes about the same amount of time (50 seconds).  Strangely, even though the delay associated with opening MD doesn't seem to be related to a project (the delay is waiting for the welcome screen with no project loaded), the exit delay only seems to happen when a project is loaded.

In additonal testing, the delay happens when closing a solution.  Opening the solution is quick, however.
Comment 1 Mikayla Hutchinson [MSFT] 2011-07-28 14:19:37 UTC
XmlReader tries to resolve DTDs unless explicitly disabled, which can cause problems on slow networks. Could you get a kill -QUIT trace on one of these hangs?
Comment 2 Mikayla Hutchinson [MSFT] 2011-11-15 11:57:11 UTC
I fixed some WelcomePage network issues in MD 2.6. Do you still have this problem?
Comment 3 Marius Ungureanu 2013-09-12 17:08:15 UTC
.