Bug 58952 - Device log does not always show content.
Summary: Device log does not always show content.
Status: CONFIRMED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: 15.6
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-22 14:42 UTC by Paul Sinnema
Modified: 2017-08-30 18:09 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 58952 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description Paul Sinnema 2017-08-22 14:42:07 UTC
The device log does not always show the logs for iOS devices. Most of the time it works the first time but as soon as you switch to another window and back the logging stops. Switching to another device (f.i. Android) and back to iOS restarts the logging (but not always, then only a restart of VS solves this).

Version information:

Microsoft Visual Studio Professional 2017 
Version 15.3.1
VisualStudio.15.Release/15.3.1+26730.8
Microsoft .NET Framework
Version 4.7.02046

Xamarin   4.6.0.295 (306f76a)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.4.0.19 (0cd0214)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.12.0.14 (bf350ba)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 1 Paul Sinnema 2017-08-22 15:16:54 UTC
Have to use the console application on the Mac server for now to get the logging.
Comment 2 Prashant [MSFT] 2017-08-23 05:58:11 UTC
I see similar behaviour the VS 2017 v15.3.1 running Xamarin 15.4 builds. The device logs (iOS & Android) does not stream in Devices logs window. We have to close and open to get the new logs or wait for couple minutes for it to refresh.

I am marking this as confirmed

# Version Information

Microsoft Visual Studio Enterprise 2017 Preview
Version 15.3.1 Preview 1.0
VisualStudio.15.Preview/15.3.1-pre.1.0+26730.8
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise


Xamarin   4.7.0.827 (ddd8750)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.5.0.3 (3e66e8e)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.14.0.4 (c70e3b5)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

Forums post 
https://forums.xamarin.com/discussion/101359/android-device-log-issues