Bug 58860 - [VSMac] SDK Manager is not installing system images (Android 8.0) in a proper location
Summary: [VSMac] SDK Manager is not installing system images (Android 8.0) in a proper...
Status: RESOLVED DUPLICATE of bug 57003
Alias: None
Product: Android
Classification: Xamarin
Component: SDK Manager ()
Version: 8.0 (15.4)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Vsevolod Kukol
URL:
Depends on:
Blocks:
 
Reported: 2017-08-17 19:33 UTC by Gonzalo Martin
Modified: 2017-08-18 18:17 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
VS Logs (30.04 KB, application/zip)
2017-08-17 19:33 UTC, Gonzalo Martin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 57003

Description Gonzalo Martin 2017-08-17 19:33:05 UTC
Created attachment 24280 [details]
VS Logs

##### Steps to reproduce #####
1. Open SDK Manager (Tools -> SDK Manager)
2. Expand 'Android 8.0 - O' from 'Platforms' tab
3. Select and install 'Google Apis Intel x86 Atom System Image' (the latest version)
4. Once installation is done, open Google Emulator Manager: Tools -> Google Emulator Manager
5. Select 'Create' and select 'Android 8.0.0 - API Level 26' as target

##### Expected result #####
It should you allow to select a CPU/ABI

##### Current result #####
You are not able to choose an image for that target.

NOTE: One possible workaround is open old sdk manager from $(AndroidSdk)/tools/android and install the same system image from there. Doing that, you're able to select an image for Android 8.0.

##### Supplemental info #####
Environment info: https://gist.github.com/gonzalonm/1575a7c2e5df633d0b233642a4ea8939
Screencast: http://www.screencast.com/t/Dxw1CNAjYn
Attached VS logs
Comment 1 Vsevolod Kukol 2017-08-18 18:17:55 UTC
The location is correct, the deprecated/old AVD Manager does not support the new image format.

*** This bug has been marked as a duplicate of bug 57003 ***