Bug 58758 - WKUIDelegate is missing method runOpenPanelWith
Summary: WKUIDelegate is missing method runOpenPanelWith
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: 3.6.0 (d15-3)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 15.4
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2017-08-14 22:17 UTC by vaibhav.kamath
Modified: 2017-09-11 12:55 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description vaibhav.kamath 2017-08-14 22:17:41 UTC
WebKit > WKUIDelegate is missing a method runOpenPanelWith

https://developer.apple.com/documentation/webkit/wkuidelegate
Comment 1 Sebastien Pouliot 2017-08-15 00:20:12 UTC
This was added in 10.12[.x]
https://developer.apple.com/documentation/webkit/wkuidelegate/1641952-webview?language=objc

xtro
!missing-protocol-member! WKUIDelegate::webView:runOpenPanelWithParameters:initiatedByFrame:completionHandler: not found

@Tim we have a slight window for 15.4 because it froze, can you add the missing API ? thanks!
Comment 2 Chris Hamons 2017-08-15 15:50:29 UTC
https://github.com/xamarin/xamarin-macios/pull/2495
Comment 3 Chris Hamons 2017-08-16 17:52:55 UTC
https://github.com/xamarin/xamarin-macios/pull/2500 for d15-4
Comment 5 Chris Hamons 2017-08-23 18:31:49 UTC
Created attachment 24381 [details]
(DO NOT USE) Wrong Repro
Comment 6 Chris Hamons 2017-08-23 18:32:13 UTC
Wrong bug. :(
Comment 7 Chris Hamons 2017-09-11 12:55:40 UTC
For clarification, since the bug itself is correct. The attachment that I renamed as (DO NOT USE) was attached to the wrong bug.