Bug 5872 - Androidtools does not handle non-ASCII device names
Summary: Androidtools does not handle non-ASCII device names
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Tools and Addins ()
Version: 4.0
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-26 16:42 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-05-22 16:09 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2012-06-26 16:42:56 UTC
Androidtools does not handle non-ASCII device names. This prevents both MonoDevelop and Visual Studio from deploying to such devices. Unfortunately this seems to be undefined in the adb spec so we'll have to reverse engineer it to find out exactly what encodings can/should be used.
Comment 1 Mikayla Hutchinson [MSFT] 2013-05-22 16:09:28 UTC
This should be fixed, I switched it to UTF8 some time back.