Bug 58712 - MSBuild does not set $(AppConfig) property to Web.config when building older ASP.NET MVC projects.
Summary: MSBuild does not set $(AppConfig) property to Web.config when building older ...
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: msbuild ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Ankit Jain
URL:
Depends on:
Blocks:
 
Reported: 2017-08-11 03:45 UTC by brian.j.suh
Modified: 2017-08-11 03:45 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 58712 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description brian.j.suh 2017-08-11 03:45:31 UTC
Using msbuild 15.2.0.0 bundled with the OS X installer for mono 5.0.1.1, I cannot build older non-.NET Core ASP.NET MVC projects because AppConfig is unset and msbuild looks for app.config instead of Web.config. I can workaround this by adding <AppConfig>Web.config</AppConfig> into a <PropertyGroup> within my project file.