Bug 58630 - UWP: controls are ignoring their renders.
Summary: UWP: controls are ignoring their renders.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-07 21:59 UTC by Brad Chase
Modified: 2017-09-27 12:54 UTC (History)
4 users (show)

Tags: fr
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brad Chase 2017-08-07 21:59:48 UTC
It seems that the majority of controls are ignoring their layouts because IsNativeStateConsistent is never being set to false.  The problem is because the control is being added to the tree before the Loaded method is being called.  Changing this causes all of our controls to render perfectly.  Some invalidates may even be ok to drop now.

I will post the fix here.
Comment 1 Brad Chase 2017-08-07 22:08:20 UTC
Linkback to PR:

https://github.com/xamarin/Xamarin.Forms/pull/1089
Comment 2 Brad Chase 2017-08-07 22:09:02 UTC
Err IsNativeStateConsistent is never being set to true...
Comment 3 Paul DiPietro [MSFT] 2017-08-08 00:32:03 UTC
I will set this to in progress until someone reviews the PR.
Comment 4 Rui Marinho 2017-09-27 12:54:35 UTC
Should be fixed on 2.4.1-pre1