Bug 5860 - MonoTouch Dialog, StyledMultilineElement of type Subtitle does not render properly
Summary: MonoTouch Dialog, StyledMultilineElement of type Subtitle does not render pro...
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-26 06:03 UTC by Dylan
Modified: 2016-02-17 17:26 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
StyledMultilineElement drawn incorrectly (14.69 KB, image/png)
2012-06-26 06:03 UTC, Dylan
Details
Drawn correctly (20.62 KB, image/png)
2016-02-17 17:25 UTC, Rolf Bjarne Kvinge [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Dylan 2012-06-26 06:03:01 UTC
Created attachment 2116 [details]
StyledMultilineElement drawn incorrectly

I have attached a screenshot of the element that has not rendered properly. 

Code:

StyledMultilineElement element;
            element = new StyledMultilineElement(
                    "Package",
                    UserController.LoggedOnUser.Network + Environment.NewLine + UserController.LoggedOnUser.Package,
                    UITableViewCellStyle.Subtitle
            );
            element.TextColor = Colors.Red;
            element.DetailColor = Colors.Blue;
Comment 1 Rolf Bjarne Kvinge [MSFT] 2016-02-17 17:25:53 UTC
Created attachment 15077 [details]
Drawn correctly

This seems to be working fine now

Test app: https://github.com/rolfbjarne/TestApp/tree/bug5860