Bug 58584 - Getting Exception on forms previewer.
Summary: Getting Exception on forms previewer.
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms Previewer ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-04 05:04 UTC by Parmendra
Modified: 2017-08-07 10:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Parmendra 2017-08-04 05:04:45 UTC
1. Open VS and open forms application.
2. Open MainPage.XAML page.
3. Open Forms Previewer (Android).

Getting Error on Preveiwer:
mono.android.DesignerException: java.lang.UnsatisfiedLinkError
	at mono.android.DesignerException.fromThrowable(DesignerException.java:46)
	at mono.android.DesignerSession.checkRenderResultForError(DesignerSession.java:187)
	at mono.android.DesignerSession.load(DesignerSession.java:239)
	at mono.android.DesignerSession.processMessage(DesignerSession.java:702)
	at mono.android.MessageListener.executeMessage(MessageListener.java:88)
	at mono.android.MessageListener$Runner.run(MessageListener.java:44)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.UnsatisfiedLinkError: md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView.n_onMeasure(II)V
	at md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView.n_onMeasure(Native Method)
	at md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView.onMeasure(XFPageRendererView.java:54)
	at android.view.View.measure(View.java:19734)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:6120)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:185)
	at android.view.View.measure(View.java:19734)
	at android.widget.RelativeLayout.measureChildHorizontal(RelativeLayout.java:715)
	at android.widget.RelativeLayout.onMeasure(RelativeLayout.java:461)
	at android.view.View.measure(View.java:19734)
	at com.android.layoutlib.bridge.impl.RenderSessionImpl.measureView(RenderSessionImpl.java:589)
	at com.android.layoutlib.bridge.impl.RenderSessionImpl.inflate(RenderSessionImpl.java:342)
	at com.android.layoutlib.bridge.Bridge.createSession(Bridge.java:429)
	at com.android.ide.common.rendering.LayoutLibrary.createSession(LayoutLibrary.java:368)
	at mono.android.DesignerSession.load(DesignerSession.java:233)
	... 4 more



Workaround: Close Mainpage.XAML and previewer and again open first previewer and then Mainpage.xaml then its working fine.

EnvironmentInfo:
VS 2015 Enterprise
XVS 4.5.0.486
Comment 1 Prashant [MSFT] 2017-08-07 06:36:37 UTC
Thanks so much for taking the time to submit this report! I’m unable to reproduce this issue using the latest Visual Studio 2017 Preview version 15.3. Please attach the following to help us reproduce this issue: 
-Detailed reproduction steps 
-Version information (Help → About Microsoft Visual Studio → Copy Info) 
-Logs (Help → Xamarin → Zip Logs (last 7 days)) 
-Optional: project to reproduce your issue
Comment 2 Parmendra 2017-08-07 10:53:55 UTC
@Prashant, Thanks for looking this issue.

I am not able to reproduce this issue. Its working fine now.
I will comment this issue when getting same issue in future.

Thanks.