Bug 58497 - NativeGatekeeper.dll could not be found {project_name}.iOS
Summary: NativeGatekeeper.dll could not be found {project_name}.iOS
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-07-31 09:00 UTC by K K
Modified: 2017-10-17 14:49 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description K K 2017-07-31 09:00:21 UTC
When I am trying to build my Xamarin.Forms project on iOS while running it shows the following error

Metadata file '..\..\packages\Microsoft.Net.Native.Compiler.1.6.2\tools\Packages\Microsoft.NETNative.Analyzer\1.0.0\analyzers\dotnet\cs\NativeGatekeeper.dll' could not be found	XamarinExamples.iOS

Please, help to solve this bug.
Comment 1 Paul DiPietro [MSFT] 2017-07-31 12:51:11 UTC
We will need a reproduction project in order to move forward with this. In the meantime you might want to try cleaning and rebuilding the project (after deleting bin/obj folders) and see if that helps. Also, does this occur on any new project or only this one in question?
Comment 2 K K 2017-08-01 08:44:30 UTC
Getting this error for all the projects not for only this project.

I did the clean and rebuild(deleting bin/obj folders) process but it won't work for me, Is there any other solution for this problem statement?
Comment 3 Paul DiPietro [MSFT] 2017-09-08 14:16:55 UTC
Please make certain that your VS installation is up to date and all necessary Xamarin components are up to date. I would be led to believe this is not specifically a Forms issue, but please let us know what occurs as of the present.
Comment 4 Paul DiPietro [MSFT] 2017-10-17 14:49:37 UTC
Marking as no response for now as there have not been further comments for some time now. If this is still an issue with the latest versions of VS/Forms, please reopen with a reproduction project for further investigation. Thanks!