Bug 58489 - mono-2.pc not installed when Mono framework is installed from xamarin.com
Summary: mono-2.pc not installed when Mono framework is installed from xamarin.com
Status: RESOLVED ANSWERED
Alias: None
Product: Installers
Classification: Mono
Component: macOS Installer ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2017-07-30 00:55 UTC by Dave Thompson
Modified: 2018-01-02 13:22 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Dave Thompson 2017-07-30 00:55:25 UTC
Mono-2.pc is not installed onto the disk in the latest Mono installer on macOS (5.2.0).
Comment 1 Chris Hamons 2017-07-31 14:05:53 UTC
So  ls /Library/Frameworks/Mono.framework//Versions/5.2.0/lib/pkgconfig/mono-2.pc shows nothing?
Comment 2 Dave Thompson 2017-07-31 14:23:06 UTC
It exists - thanks - I've done a ln -s now to the package folder (/usr/local/lib/pkgconfig)
Comment 3 Chris Hamons 2017-07-31 14:41:33 UTC
So I don't see a mono link in /usr/local/lib/pkgconfig/ locally.

Is this still an issue?
Comment 4 Alexander Köplinger [MSFT] 2018-01-02 13:22:24 UTC
I believe this is expected, we don't create a symlink in /usr/local/lib/pkgconfig/.

You can add /Library/Frameworks/Mono.framework/Versions/Current/lib/pkgconfig to the PKG_CONFIG_PATH environment variable to make sure pkg-config finds mono-2.