Bug 58457 - Build Error when using : using Google.MobileAds;
Summary: Build Error when using : using Google.MobileAds;
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.99 (xcode9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-07-28 12:57 UTC by Amru Rosyada
Modified: 2017-08-28 20:34 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Amru Rosyada 2017-07-28 12:57:36 UTC
Build Error when using : using Google.MobileAds;

and call : MobileAds.Configure("my pub id"); from my AppDelegate.cs

Using Mono Version 5.0.1

I add package from nuget : Firebase API iOs Admob Library

Error output:

/Volumes/My Data/Project/My Project/Mangakakalot/iOS/MTOUCH: Error MT5216: Native linking failed for '/Volumes/My Data/Project/My Project/Mangakakalot/iOS/obj/iPhone/Debug/device-builds/iphone6.1-10.3.3/mtouch-cache/arm64/libGoogle.MobileAds.dll.dylib'. Please file a bug report at http://bugzilla.xamarin.com (MT5216) (Mangakakalot.iOS)

Regards,
Comment 1 Sebastien Pouliot 2017-07-28 15:02:46 UTC
Please include your full build logs, test case (to reproduce) and all version information.

To get full build logs just set the log verbosity to diagnostic at the following locations:
- On Visual Studio for Mac: Preferences > Projects > Build
- On Visual Studio for Windows: Tools > Options > Projects and Solutions > Build and Run

On Visual Studio Windows you also want to add `-v -v -v -v` to the mtouch additional arguments by right-clicking the project in the solution explorer and selecting `Properties`.
Note: this is done automatically on Visual Studio for Mac when the log verbosity is set to diagnostic.

Easiest way to get exact version information:
- On Visual Studio for Mac: "Visual Studio" menu, "About Visual Studio" item, "Show Details" button.
- On Visual Studio for Windows: "Help menu", "About Microsoft Visual Studio" item.
Then copy/paste the version information (you can use the "Copy Information" button).
Comment 2 Vincent Dondain [MSFT] 2017-08-28 20:34:56 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!