Bug 58404 - [macOS] FormsGallery navigation fails to push correct page after a few navigation events
Summary: [macOS] FormsGallery navigation fails to push correct page after a few naviga...
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Mac ()
Version: 2.3.5
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2017-07-26 00:51 UTC by David Ortinau [MSFT]
Modified: 2017-07-26 23:47 UTC (History)
3 users (show)

Tags: macos, navigation, ac
Is this bug a regression?: ---
Last known good build:


Attachments
sample app (803.54 KB, application/zip)
2017-07-26 00:51 UTC, David Ortinau [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 58404 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description David Ortinau [MSFT] 2017-07-26 00:51:04 UTC
Created attachment 23802 [details]
sample app

https://www.screencast.com/t/ZsCi9M3En4

Run the FormsGallery sample (attached) and navigate to different sample control pages. Once you get down into the Cell renderers, things stop navigating as expected and all you get are the Label page. 

If you go instead directly to one of the Cell pages it'll render. I observed once that the back button didn't render in the title/navigation bar area.