Bug 58402 - AsyncImageAndroid sample throwing System.Net.WebException: Error: SecureChannelFailure (The authentication or decryption has failed.)
Summary: AsyncImageAndroid sample throwing System.Net.WebException: Error: SecureChann...
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 7.3 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2017-07-25 20:51 UTC by Ben Beckley
Modified: 2017-07-25 20:51 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 58402 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Ben Beckley 2017-07-25 20:51:45 UTC
Getting the following exception with the the AsyncImageAndroid[0] sample app. I haven't tried deploying to an emulator, but I am fairly certain it will repro there as well.
https://gist.github.com/BenBeckley/58319d905eb0043cb8834bed8c63da39#file-gistfile1-txt-L368-L391

Reproduction Steps:
1) Open sample in IDE (VSM or VS, repros regardless)
2) Deploy to device
3) Press the "DOWNLOAD" button
Expected: Image downloads and is displayed properly
Actual: Getting the above exception

This occurs when using XA 7.3.1.2 and is reproducible with 15.3 XA builds as well.
additional env info: https://gist.github.com/BenBeckley/ccc217759469f92f7a9ec39546a0763c

Marking this as confirmed as I have reproduced it on two separate machines.

[0] https://github.com/xamarin/monodroid-samples/tree/master/AsyncImageAndroid