Bug 58362 - Visual Studio 2015, Analyze > Xamarin Profiler option is unavailable
Summary: Visual Studio 2015, Analyze > Xamarin Profiler option is unavailable
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Profiler Integration ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: Highest blocker
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-07-25 12:35 UTC by Swati Gangrade
Modified: 2017-08-28 20:41 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: Yes
Last known good build:


Attachments
Logs (5.80 KB, application/x-zip-compressed)
2017-07-25 12:35 UTC, Swati Gangrade
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Swati Gangrade 2017-07-25 12:35:38 UTC
Created attachment 23779 [details]
Logs

Bug Description:-Unable to profile the application from Visual Studio as Xamarin Profiler option is unavailable in Analyze

=======================================================
Environment Info:
- Operating System Windows 10 Pro
- Microsoft Visual Studio Enterprise 2015 	
- Microsoft .NET Framework Version 4.7.02053
- Xamarin.VisualStudio Version- 4.7.0.823 (53465e0)
- Xamarin. Android Version - 7.5.0.0 (bbf378a)
- Xamarin.iOS - 10.14.0.0 (38d3a2b)
- XamarinProfiler.Windows Version -1.5.6-27
- Xamarin.Simulator.Version -1.1.3.21

Detailed Environment Info:- https://gist.github.com/gangrade-swati/a5d55bd27563c5936c994abd635dfe5e
=======================================================

Repro Steps:

1. Launch Visual Studio 2015
2. Create  File -> New -> Project -> Android -> Single-View App (Android) 
3. Clean and Build the project
4. Click Analyze from top menu bar

Actual Result- Xamarin Profiler option is not present

Expected Result- Xamarin Profiler option should be present in Analyze menu and user should be able to profile the application 

=======================================================
Frequency of Reproduction:
Happens every time (100% failure rate)
=======================================================

Test Rail Info:

Test Suit link:- https://testrail.xamarin.com/index.php?/plans/view/50881
Test Case-https://testrail.xamarin.com/index.php?/tests/view/16088367&group_by=tests:assignedto_id&group_order=asc&group_id=-1

=======================================================

Supplemental Information:

Build Taken from:
https://github.com/xamarin/release-manifests/blob/d15-4/d15-4/2017-07-17_215424-15.4-alpha1.json
=========================================================================

Screencast:- https://www.screencast.com/t/NI8sxRtJ
=========================================================================

IDE Logs are attached.
Comment 1 Swati Gangrade 2017-07-25 12:50:58 UTC
We Checked 4 machine on 3 machine option is not displayed and on 1 machine it is working fine.Following is the build info of machine on which it is working fine

Build Info : https://gist.github.com/gangrade-swati/824b43b98a0e23373ab5b59880b43a3b
Comment 2 Jose Gallardo 2017-08-15 18:16:24 UTC
Can you please check if this can be reproducible on latest 15.4 bits?
We fixed an issue on the Activation assembly which seems to be causing this bug as well.

As reference:

https://bugzilla.xamarin.com/show_bug.cgi?id=58360#c10
Comment 6 Ben Beckley 2017-08-28 20:41:37 UTC
I am not able to reproduce this with XVS 4.7.0.922 (46cf47c3f) and Profiler 1.5.6.42 (4fceca54e).

env info: https://gist.github.com/BenBeckley/c34f144865d6d1241f0c1bcf30f84066

https://www.screencast.com/t/JRTAhz5w08HA