Bug 58152 - [VSfM][7.1.0.1281]- Package Xamarin.Forms 2.3.4.247 is not compatible with netstandard1.4/1.5 (.NETStandard,Version=v1.4/v1.5)
Summary: [VSfM][7.1.0.1281]- Package Xamarin.Forms 2.3.4.247 is not compatible with ne...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.5
Hardware: PC Mac OS
: Normal major
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-07-14 07:15 UTC by Gaurav Ganorkar
Modified: 2017-07-24 07:41 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: No
Last known good build:


Attachments
logs (102.79 KB, application/x-zip-compressed)
2017-07-14 07:15 UTC, Gaurav Ganorkar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Gaurav Ganorkar 2017-07-14 07:15:55 UTC
Created attachment 23552 [details]
logs

Description
-When created Xamarin.FORms>PCL project and Retarget the PCL to netstandard1.4/1.5 , So while restoring the packages getting Package Xamarin.Forms 2.3.4.247 is not compatible with netstandard1.4/1.5 (.NETStandard,Version=v1.4/v1.5)

I have also tried with lower xamarin.Forms version but it still getting the same issue

Build info
Version 7.1 Preview (7.1 build 1281) d15-3 
https://gist.github.com/ganorkargaurav/9d7d0d67c6a36c7f332fbd1b90bb9d95

Steps to Reproduce
1) Create a new Blank Forms App, choose PCL sharing style, use XAML interfaces
2) Right click on the PCL, add a new file, observe the Forms item templates in the dialog.
3) Click cancel
4) Retarget the PCL to netstandard1.4

Actual
-Restoring packages fails due to the xamarin.forms packages incompatibility issue with .Net standard v1.4/1.5

Expected
-Packages should be added successfully

Screencast link
-https://www.screencast.com/t/eaY3dTaQX

Logs have been attached
Comment 1 Jimmy [MSFT] 2017-07-14 15:03:37 UTC
Support for .NET Standard is available starting with Forms 2.3.5. I was able to add the 2.3.5-pre6 package to a project targeting netstandard-1.5.
Comment 2 Neeraj Deshmukh 2017-07-24 07:41:49 UTC
Verified Visual Studio Community 2017 for Mac (Preview)
Version 7.1 Preview (7.1 build 1289)
Gist: https://gist.github.com/gangrade-swati/9371e66f205906afa0a2918cad5d1e74