Bug 58076 - Effects not working
Summary: Effects not working
Status: CONFIRMED
Alias: None
Product: Live Player
Classification: Xamarin
Component: Mobile App ()
Version: 1.0.253
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-07-11 14:19 UTC by Martin Jørgensen
Modified: 2018-04-26 10:54 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 58076 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description Martin Jørgensen 2017-07-11 14:19:34 UTC
Effects does not work in Xamarin Live Player:

<Entry x:Name="LoginName" Text="" TextColor="Black" BackgroundColor="White" Placeholder="Login" PlaceholderColor="LightGray">
  <Entry.Effects>
    <effects:EntryRemoveLineEffect />
  </Entry.Effects>
</Entry>

Causes:

"Vizualization Error":
Object of type 'NInterpret.InterpretedObject' cannot convert to type 'Xamarin.Forms.Effect'. (ArgumentException)
Comment 1 Glenn Rockland 2017-07-11 21:52:32 UTC
Similarly, Effects not working in iOS (device and simulator).  OK in Android. VS2015 v.3 Xamarin 4.5.0.475 Xamarin.iOS 10.10.0.35
OnAttached() not being called.
Comment 2 cfin 2018-04-26 10:54:32 UTC
Any word on a fix for this yet?