Bug 5802 - MonoDevelop stops responding when cancelling deployment during deployment
Summary: MonoDevelop stops responding when cancelling deployment during deployment
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-21 10:59 UTC by Dylan
Modified: 2012-09-20 05:44 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dylan 2012-06-21 10:59:03 UTC
Steps to reproduce:
- In a Mono for Android solution with an android device plugged in
- Press Control + F5 to 'Start program without debugging'
- While it's busy deploying to the device, press Shift + F5 to stop the process

MonoDevelop becomes completely unresponsive at this point. 
Version 3.0.3.2
Comment 1 Atsushi Eno 2012-09-20 05:44:53 UTC
We had been improving ADB connection part of the MD. With the latest MD and MfA, I tried two cancellations, one while removing previous version of app (case 1), and another while installing app on target (case 2), and they did not reproduce anymore. Actually to cancel the task I had to rather click the cancel button on "Deploy to Device" pane rather than CTRL+f5 (which now requires another dialog confirmation for "stopping" the execution operation). So they are likely gone.

case 1--------
Detecting installed packages

Waiting for packaging to complete

Removing previous version of application

Deployment canceled



case 2--------
Detecting installed packages

Waiting for packaging to complete

Removing previous version of application

Installing application on device

Deployment canceled

If you still see the same problem, please reopen.