Bug 5795 - Text in input field is incomplete or rendering failed
Summary: Text in input field is incomplete or rendering failed
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: unspecified
Hardware: PC Linux
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-21 05:55 UTC by news_001
Modified: 2017-09-01 11:56 UTC (History)
3 users (show)

Tags: mono-community
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 5795 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description news_001 2012-06-21 05:55:58 UTC
Stack:
Ubuntu 11.04
Mono JIT compiler 2.6.7 (Debian 2.6.7-5ubuntu3)
Keepass 2.19

Issue:
Last character of a text in a input field is not displayed.

Steps to reproduce:
Precondition: you have a "Entry" with a password entered in keepass database.
1) Open Keepass database file
2) When i double click on a "Entry" in Keepass
3) click on "Show/hide password using asterisks"-button to see the password
4) last character of the password is missing

Workaround:
1) hit "end"-key
2) enter a character
= the missing character become visable an your new character too.

Sub-Issue:
Cursor position is BEFORE your last character, which is confusing. I expect it to have it after the last character entered.
Comment 1 Zoltan Varga 2012-06-21 07:50:06 UTC
-> winforms.
Comment 2 Michael Monreal 2013-03-09 17:23:50 UTC
I can reproduce this with mono-winforms-2.10.8, very annoying