Bug 57949 - [VS2017][Xcode-9 beta][4.6.0.307]-"System.IO.FileNotFoundException: Could not load file or assembly 'Mono.Posix, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies." when attempting to start apps
Summary: [VS2017][Xcode-9 beta][4.6.0.307]-"System.IO.FileNotFoundException: Could not...
Status: RESOLVED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.6.0 (15.3)
Hardware: PC Windows
: High critical
Target Milestone: Xcode9
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-07-05 15:47 UTC by Gaurav Ganorkar
Modified: 2017-07-05 18:21 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: No
Last known good build:


Attachments
IDE logs (5.96 KB, application/x-zip-compressed)
2017-07-05 15:47 UTC, Gaurav Ganorkar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Gaurav Ganorkar 2017-07-05 15:47:48 UTC
Created attachment 23304 [details]
IDE logs

This bug is similar to the bug https://bugzilla.xamarin.com/show_bug.cgi?id=56787.
It's working fine with Android devices.

Description
-While deploying the CrossplatformDebugging sample , Application is getting terminated as soon as getting launched with the error 
System.IO.FileNotFoundException: Could not load file or assembly 'Mono.Posix, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies." when attempting to start apps

Build info-
Microsoft Visual Studio Enterprise 2017 Preview
Version 15.3.0 Preview 3.0
VisualStudio.15.Preview/15.3.0-pre.3.0+26621.2
Microsoft .NET Framework Version 4.7.02046
Xamarin 4.6.0.307 (2f5889a)
Xamarin.Android SDK 7.4.0.13 (f6289cd)
Xamarin.iOS and Xamarin.Mac SDK   10.99.0.70 (5e98e96)

Xcode used - Xcode 9 beta

Steps to Reproduce
1-Open CrossplatformDebugging sample for QualityAssurance sample
2-Set startup project "iOS debugging"
3-Deploy the application on Real device with iOS 11 or iOS 10 and Observe

Actual
-Application is getting terminated with the error 
System.IO.FileNotFoundException: Could not load file or assembly 'Mono.Posix, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies." when attempting to start apps

Expected 
-Application should be deployed in Debug mode

Screencast link
-https://www.screencast.com/t/Dk3T2Y0W

Logs have been attached.

Getting exception over
System.IO.FileNotFoundException: Could not load file or assembly 'Mono.Posix, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies. The system cannot find the file specified.
File name: 'Mono.Posix, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'
   at Mono.Debugging.Soft.SoftDebuggerSession.ResolveSymbolicLink(String path)
   at Mono.Debugging.Soft.SoftDebuggerSession.PathsAreEqual(String p1, String p2)
   at Mono.Debugging.Soft.SoftDebuggerSession.FindLocationByMethod(MethodMirror method, String file, Int32 line, Int32 column, Boolean& insideTypeRange)
   at Mono.Debugging.Soft.SoftDebuggerSession.FindLocationByType(TypeMirror type, String file, Int32 line, Int32 column, Boolean& genericMethod, Boolean& insideTypeRange)
   at Mono.Debugging.Soft.SoftDebuggerSession.ResolveBreakpoints(TypeMirror type)
   at Mono.Debugging.Soft.SoftDebuggerSession.HandleTypeLoadEvents(TypeLoadEvent[] events)
   at Mono.Debugging.Soft.SoftDebuggerSession.HandleEventSet(EventSet es)
   at Mono.Debugging.Soft.SoftDebuggerSession.EventHandler()
Comment 1 Gaurav Ganorkar 2017-07-05 15:53:32 UTC
Note- This issue have been observed on Both iOS real devices and Simulator.
Comment 2 GouriKumari 2017-07-05 16:39:10 UTC
This is an xcode9 bug and is similar to one raised in d15-3, bug 56787.
Comment 3 Jose Gallardo 2017-07-05 17:36:31 UTC
This seems to be related to a wrong Xamarin.Debugging VSIX installed on the IDE.
We need to follow up identifying what's the right version and how QA can install it.