Bug 57882 - iPad Pro 10,5''
Summary: iPad Pro 10,5''
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.12 (d15-3)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-30 13:17 UTC by Alain
Modified: 2017-07-25 07:50 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
LaunchScreen (5.50 KB, application/xml)
2017-07-06 11:20 UTC, Alain
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Alain 2017-06-30 13:17:00 UTC
Hello,

I want to test my application on iPad Pro 10.5 and I find that my application doesn't put in the right resolution.

On the iPad Pro 12.5, it's Ok but not on the 10.5.

On this one, the application is zoomed in? Is this normal?

Alain
Comment 1 Manuel de la Peña [MSFT] 2017-07-03 10:50:57 UTC
Hello,

Can you please provide the full information of your environment as well as a sample test app that we can use to test the issue.
Comment 2 Alain 2017-07-03 12:28:00 UTC
I'm off for the moment so I can not make you an application test but it's relatively simple.

I have a launchpad screen. When I'm on a 9.7 and 12.9 iPad, the screen automatically adjusts to resolution.

When I am in 10.5, the screen is displayed in 9.7 zoomed.
Comment 3 Manuel de la Peña [MSFT] 2017-07-05 15:47:02 UTC
@Alain can you please double check that you have a 10.5 launch image in your project?
Comment 4 Alain 2017-07-06 11:20:27 UTC
Created attachment 23339 [details]
LaunchScreen

I have a single launchscreen that fits according to the resolution. I do not know what you mean.

I'm sending you my launchscreen
Comment 5 Sebastien Pouliot 2017-07-10 12:40:10 UTC
Apple requires some extra work [1] if you're using Xcode 8.3 (released before the hardware). Otherwise if assume your app is unaware of the new resolution.

[1] https://stackoverflow.com/a/44393188
Comment 6 Alain 2017-07-25 07:50:42 UTC
OK, I have seen the problem.

Thanks

Alain