Bug 57818 - Very slow solution load times with latest Xamarin Extension installed (+~450 seconds)
Summary: Very slow solution load times with latest Xamarin Extension installed (+~450 ...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.6.0 (15.3)
Hardware: PC Windows
: High major
Target Milestone: 15.4
Assignee: Adrian Alonso
URL:
Depends on:
Blocks:
 
Reported: 2017-06-28 03:50 UTC by PaulH
Modified: 2017-07-04 01:33 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of Visual Studio Performance dialog showing 445s extra load time (46.58 KB, image/jpeg)
2017-06-28 03:50 UTC, PaulH
Details
ActivityLog from VS startup (500.49 KB, application/xml)
2017-06-28 08:52 UTC, PaulH
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description PaulH 2017-06-28 03:50:35 UTC
Created attachment 23160 [details]
Screenshot of Visual Studio Performance dialog showing 445s extra load time

Xamarin for Visual Studio v4.6.0.560 [Experimental]
Visual Studio 2017 15.3.0 Preview 3

Opening Visual Studio is quick, but as soon as I try to load a Xamarin project it takes over 7 minutes to load (about 460 seconds +/- 20s).  This was fine when using VS 15.3 Preview 2 and Xamarin for VS v4.6.0.240, but updating to the latest preview today (to get the Xamarin Live Player) broke it.

Loading does not tax the CPU or disk much, it simply sits on the "Preparing Solution..." dialog the entire time. Closing the solution (not VS) and opening it again does not take long.
Comment 1 PaulH 2017-06-28 04:05:14 UTC
More info: possibly related to corruption in a specific project.  I forced VS to exit during one of the long waits then reopened Visual Studio.  It repaired the solution and it no longer takes as long.

Closing as not reproducible because it seems like a quirk with my solution.
Comment 2 PaulH 2017-06-28 08:47:55 UTC
Reopening - this issue reappeared after a reboot.

Attaching VS Logs, there is a huge delay prior to the XamarinAndroidPackage load - this time nearly 12 minutes(!!):

  ...
  <entry>
    <record>647</record>
    <time>2017/06/28 08:23:25.118</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>End package load [CSharpPackage]</description>
    <guid>{13C3BBB4-F18F-4111-9F54-A0FB010D9194}</guid>
  </entry>
  <entry>
    <record>648</record>
    <time>2017/06/28 08:35:02.823</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>End package load [XamarinAndroidPackage]</description>
    <guid>{296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6}</guid>
  </entry>
  <entry>
    <record>649</record>
    <time>2017/06/28 08:35:02.838</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
    <guid>{DE353D20-56EB-11D2-BF19-00C04F79EFBC}</guid>
  </entry>
  ...
Comment 3 PaulH 2017-06-28 08:52:25 UTC
Created attachment 23164 [details]
ActivityLog from VS startup

Activity Log from VS startup (devenv.exe /log)

Shows almost > 11 minutes delay before loading XamarinAndroidPackage.  The entire time VS was sitting on "Preparing Solution..."
Comment 4 Adrian Alonso 2017-06-28 13:16:48 UTC
Hi Paul,

Is this issue only happening with a specific solution or does it happen with any Android project? You could also try to open the Android Tool Options Page (Tools -> Options -> Xamarin -> Android) which triggers the loading of the Android package and  and check if that action also takes so long.

Another thing you could try is to delete the hidden .vs folder of the solution and see if that makes any difference.

I will try to reproduce the issue and will keep you posted.

Sorry for inconvenience and thanks,
Adrian
Comment 5 Jose Gallardo 2017-06-30 13:34:38 UTC
Setting target milestone to 15.4, as the issue is reported for the Player preview build, and not for the regular releases.
Comment 6 PaulH 2017-07-03 00:29:34 UTC
I've been trying without success to reproduce this on another similar machine but can't.  The original install had some other issues related to Windows which could not be resolved without a Windows Repair, and now the issue can't be reproduced there either.

Closing again as not reproducible, sorry.
Comment 7 Adrian Alonso 2017-07-04 01:33:17 UTC
Thanks Paul, we could not reproduce the issue so far either. We will reopen the bug if we find something wrong on our side. Adrian