Bug 57678 - [xcode9] IBTool errors with Xcode 9 beta 2
Summary: [xcode9] IBTool errors with Xcode 9 beta 2
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.99 (xcode9)
Hardware: PC Mac OS
: Normal major
Target Milestone: Xcode9
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-21 22:22 UTC by Vincent Dondain [MSFT]
Modified: 2017-06-21 22:28 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Vincent Dondain [MSFT] 2017-06-21 22:22:46 UTC
/Users/vidondai/Projects/MyIOSProject/MyIOSProject/LaunchScreen.storyboard: Error: 2017-06-21 18:14:46.306 ibtoold[81945:20653219] [MT] DVTPlugInLoading: Failed to load code for plug-in com.apple.dt.IDE.IDEInterfaceBuilderCocoaTouchIntegration (/Applications/Xcode9-beta2.app/Contents/PlugIns/IDEInterfaceBuilderCocoaTouchIntegration.framework), error = Error Domain=NSCocoaErrorDomain Code=3588 "dlopen(/Applications/Xcode9-beta2.app/Contents/PlugIns/IDEInterfaceBuilderCocoaTouchIntegration.framework/IDEInterfaceBuilderCocoaTouchIntegration, 265): Symbol not found: _SimFeatureExternalDisplay

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets(3,3): Error: ibtool exited with code 134 (MyIOSProject)

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets(3,3): Error MSB4018: The "IBTool" task failed unexpectedly.
System.ArgumentException: Failed to parse PList data type:  ---> System.ArgumentException: Must specify valid information for parsing in the string.
  at System.Enum+EnumResult.SetFailure (System.Enum+ParseFailureKind failure, System.String failureMessageID, System.Object failureMessageFormatArgument) [0x00024] in /private/tmp/source-mono-2017-04/bockbuild-2017-04/profiles/mono-mac-xamarin/build-root/mono-x64/mcs/class/referencesource/mscorlib/system/enum.cs:318 

See full build log: https://gist.github.com/VincentDondain/66f29bdf30e759af3601c012db24ad1c

This is happening with a Single View iOS template and Xcode9-beta2 defined in Apple SDK location.
Comment 1 Vincent Dondain [MSFT] 2017-06-21 22:28:40 UTC
Never-mind, I did not launch Xcode 9 beta 2, therefore did not install the components.