Bug 57522 - mono 5.0 print message
Summary: mono 5.0 print message
Status: RESOLVED ANSWERED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: 5.0 (2017-02)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-15 11:46 UTC by Enrico Sada
Modified: 2017-06-15 11:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Enrico Sada 2017-06-15 11:46:01 UTC
Some error/warning/info message on **console output** in mono 5.0 (is ok mono 4.8)

`error non-IL or abstract method with non-zero RVA`


# Repro steps

Use FCS in many settings with Mono 5. Example is FSAC regression tests, e.g. https://travis-ci.org/fsharp/FsAutoComplete/jobs/243195680#L2206, or with emacs: fsharp/emacs-fsharp-mode#130

# Expected behavior

No debug output on standard output.

# Actual behavior

`non-IL or abstract method with non-zero RVA` printed


ref https://github.com/fsharp/FSharp.Compiler.Service/issues/780 for a repro

already reported in https://bugzilla.xamarin.com/show_bug.cgi?id=56258 but that was with multiple issues, so maybe was not fixed.
Comment 1 Enrico Sada 2017-06-15 11:50:57 UTC
Was an f# compiler issue.

ref https://github.com/fsharp/FSharp.Compiler.Service/issues/780#issuecomment-308706817

> Different versions of Mono ship different versions of the compiler. The warning comes from the compiler, so I don't think that this should be considered a Mono issue