Bug 57514 - [XVS][Xamarin:4.5.0.485] Getting DEP3321 error while deployment for any target version.
Summary: [XVS][Xamarin:4.5.0.485] Getting DEP3321 error while deployment for any targe...
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-15 06:44 UTC by Rehan Parvez
Modified: 2017-06-19 14:26 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot (82.86 KB, image/png)
2017-06-15 06:44 UTC, Rehan Parvez
Details
logs (177.12 KB, application/zip)
2017-06-15 06:44 UTC, Rehan Parvez
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Rehan Parvez 2017-06-15 06:44:14 UTC
Created attachment 22905 [details]
screenshot

Steps to reproduce : 
1. Create a Xamarin Forms app.
2. Set .UWP (Universal Windows Project) project as startup project.
3. Select target version by Right click on .UWP project > Properties > Application > Target Version.
4. Build and Deploy the app.

Expected Version : App should build successfully and get deployed.

Actual Result : While deploying the app, DEP3321 error is observed.

Build Environment: https://gist.github.com/RehanParvez/01779f20ab8d9bd45c7042dd95843846


Please find attached screenshot and logs.

Note: If you are unable to reproduce this issue please set build & deploy in configuration manager.
Steps: 1. Right click the main solution.
2. Go to Properties > configuration properties
3. Check both checkboxes build and deploy for UWP project.

dependency: https://bugzilla.xamarin.com/show_bug.cgi?id=44661
Comment 1 Rehan Parvez 2017-06-15 06:44:54 UTC
Created attachment 22906 [details]
logs
Comment 2 Joaquin Jares 2017-06-19 14:26:03 UTC
This is expected, and also not our bug: https://winplatform.wordpress.com/2015/07/28/error-dep3321-cant-deploy-to-windows-10-mobile/
It depends on what device you're using, and what target you're choosing on step 3. Clsing as Invalid, because this is not Xamarin.