Bug 57485 - Entry inside a Frame has Focus issues on Android
Summary: Entry inside a Frame has Focus issues on Android
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.5
Hardware: PC Mac OS
: High major
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2017-06-14 13:51 UTC by Jon Dick
Modified: 2017-06-23 12:58 UTC (History)
3 users (show)

Tags: android, entry, ac
Is this bug a regression?: ---
Last known good build:


Attachments
Repro (78.75 KB, application/zip)
2017-06-14 13:51 UTC, Jon Dick
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Dick 2017-06-14 13:51:55 UTC
Created attachment 22887 [details]
Repro

It's a bit hard to describe the behaviour in words, so here's a video of the behaviour: https://db.tt/7vXaqn8rFu

Basically, you tap on an Entry, Tap somewhere else to hide the keyboard, and tap the entry again and it seems to be half focused.  The cursor either doesn't show up or shows up frozen, but the keyboard doesn't pop up.

This doesn't appear to happen with v2.3.4.x of Forms, only the 2.3.5.x prereleases.

It also looks like when this happens, the Entry's Focus event never fires either.

ADB shows this warning when this happens:
[IInputConnectionWrapper] finishComposingText on inactive InputConnection

The Entry seems to need to be in a Frame for this bug to occur.

I'm attaching a very simple repro solution.
Comment 1 Rui Marinho 2017-06-23 10:13:36 UTC
Hi Redth i think we got this fixed recently with fixes to transparent and touch on Android, can you test this nuget 2.3.6.112-nightly ? You can install using the nightly feed https://blog.xamarin.com/try-the-latest-in-xamarin-forms-with-nightly-builds/
Comment 2 Jon Dick 2017-06-23 12:56:43 UTC
Confirmed, working correctly in nightly.
Comment 3 Rui Marinho 2017-06-23 12:58:14 UTC
Should be fixed on 2.3.6-pre1