Bug 57420 - Follow-up to Bug 56787: "Mono.Debugging.VisualStudio" extension is not yet up-to-date in upstream VS 2017 installer manifest
Summary: Follow-up to Bug 56787: "Mono.Debugging.VisualStudio" extension is not yet up...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- major
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks: 56787
  Show dependency tree
 
Reported: 2017-06-13 05:01 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2017-07-12 06:09 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2017-06-13 05:01:05 UTC
Follow-up to Bug 56787: "Mono.Debugging.VisualStudio" extension is not yet up-to-date in upstream VS 2017 installer manifest

This is a tracking bug to follow the status of the inclusion of Mono.Debugging.VisualStudio version 1.0.57 or higher into the VS 2017 installer manifest.

One consequence of this issue is that the candidate fix for Bug 56787 is not installed into the required location in the "Mono.Debugging" extension folder in the latest VS 2017 update, so users are still hitting Bug 56787.




## Note to the Xamarin team

This bug is a bit different from non-public Bug 57362.  In this case, it seems that the most recent Visual Studio 2017 installer manifest simply has not yet been updated to include the latest version of the "Mono.Debugging.VisualStudio" extension.  The current released versions of the Mono.Debugging extension all have "good" version numbers of "1.0.55" or lower, so the issue in non-public Bug 57362 is not relevant.




## Steps followed to test

Install VS 2017 version 15.2 (26430.13).




## Example results



### BAD for a new VS 2017 install

Mono.Debugging.VisualStudio version [1]
Installed: 1.0.55
Expected:  1.0.57



### BAD after updating from VS 2017 version 15.1 (26403.3) with XamarinVS 4.4.0.34 (3f99c5a)

Mono.Debugging.VisualStudio version [1]
Before:   1.0.39
After:    1.0.55
Expected: 1.0.57



[1] From:
> C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\Mono.Debugging\extension.vsixmanifest



## Additional testing environment info (brief)

Microsoft .NET Framework
Version 4.7.02046

Windows 10 (64-bit) Version 1703 (OS Build 15063.332)
US English locale, US Eastern time zone
Comment 1 Joaquin Jares 2017-06-19 13:02:30 UTC
Fixed in 15.3. New version is 4.6.1.