Bug 57366 - Text is not visible initially in custom Entry after upgrading to Xamarin.Forms v2.3.4.247
Summary: Text is not visible initially in custom Entry after upgrading to Xamarin.Form...
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.4
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-12 12:16 UTC by Paul Anderson
Modified: 2017-06-21 13:28 UTC (History)
4 users (show)

Tags: ac, uwp, entryrenderer, custom, style
Is this bug a regression?: ---
Last known good build:


Attachments
Demo Sample (132.67 KB, application/zip)
2017-06-12 12:16 UTC, Paul Anderson
Details
Demo Sample2 (134.02 KB, application/zip)
2017-06-13 06:42 UTC, Paul Anderson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 57366 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Paul Anderson 2017-06-12 12:16:55 UTC
Created attachment 22828 [details]
Demo Sample

I am using an Entry inside PopupPage(Rg.Plugins.Popup) and for better look, I have overridden the style of Entry in Xamarin.Forms UWP platform. In the style, I have set center vertical alignment for the ScrollViewer(ContentElement) used in it's template. This style worked as expected till Xamarin.Forms v2.3.3.193. Recently I have upgraded Xamarin.Forms Nuget package to v2.3.4.247, after that the content in entry disappeared. But it displayed once the control is focused. Can you please look into this and resolve this issue? And I have attached a sample
Comment 1 Paul Anderson 2017-06-13 06:42:52 UTC
Created attachment 22847 [details]
Demo Sample2

Use Demo Sample2 for error reproducing.
Comment 2 Jimmy [MSFT] 2017-06-20 16:23:38 UTC
I ran the "Demo Sample2" project and was able to see the issue described. I'm marking this as confirmed and we will look into this further.


### Version Tests
2.3.6.111-nightly   BAD
2.3.5-pre3          BAD
2.3.4.247           BAD
2.3.3.193           GOOD