Bug 57365 - Label.VerticalTextAlignment always align in top (Start) on macOS
Summary: Label.VerticalTextAlignment always align in top (Start) on macOS
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Mac ()
Version: 2.3.5
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-12 10:53 UTC by Thomas Hagen
Modified: 2017-06-12 11:22 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Thomas Hagen 2017-06-12 10:53:31 UTC
Observed in Xamarin.Forms version 2.3.5.239-pre3

<Label Text="27" HorizontalTextAlignment="Center" VerticalTextAlignment="Center" />

Center and End don't work.
Comment 1 Thomas Hagen 2017-06-12 11:09:34 UTC
Naturally aligned in some context, fx Grid

<Grid>
  <Label Text="One"   Grid.Row="0" VerticalTextAlignment="Start"/>
  <Label Text="Two"   Grid.Row="1" VerticalTextAlignment="Center"/>
  <Label Text="Three" Grid.Row="2" VerticalTextAlignment="End"/>
</Grid>
Comment 2 Thomas Hagen 2017-06-12 11:22:10 UTC
I don't know if it's a bug... i just seem to behave differently on iOS & macOS... I will investigate more, so I'm closing this issue again.