Bug 57339 - MSBuild process produces high CPU usage due to incorrect parent process monitor on XMA
Summary: MSBuild process produces high CPU usage due to incorrect parent process monit...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.6.0 (15.3)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-09 19:26 UTC by mag@xamarin.com
Modified: 2017-06-12 14:42 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description mag@xamarin.com 2017-06-09 19:26:02 UTC
When building iOS projects, XMA uses a parent process monitoring logic to avoid having orphan MSBuild processes after VS is closed. That logic is incorrectly run every 10 milliseconds, which causes high CPU usage and unexpected behaviors.
Comment 1 xamarin-release-manager 2017-06-12 14:42:02 UTC
Fixed in version 4.7.0.22 (master)

Author: Mauro Agnoletti
Commit: 1842faa0ec5477273e8e602648348ef17d79a7e0 (xamarin/XamarinVS)